summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 9ba00a2..1c11194 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
# Copyright (C) 2011 Lars Wirzenius <liw@liw.fi>
#
# This program is free software; you can redistribute it and/or modify
@@ -43,13 +43,13 @@ class GenerateManpage(build):
def run(self):
build.run(self)
- print 'building manpages'
+ print('building manpages')
cmds = ['cmdtest']
if markdown_version:
cmds.append('yarn')
for x in cmds:
with open('%s.1' % x, 'w') as f:
- subprocess.check_call(['python', x,
+ subprocess.check_call(['python3', x,
'--generate-manpage=%s.1.in' % x,
'--output=%s.1' % x], stdout=f)
@@ -76,7 +76,7 @@ class Check(Command):
def run(self):
if markdown_version:
subprocess.check_call(
- ['python', '-m', 'CoverageTestRunner',
+ ['python3', '-m', 'CoverageTestRunner',
'--ignore-missing-from', 'without-tests'])
if os.path.exists('.coverage'):
os.remove('.coverage')