summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2017-07-05 13:31:23 +0300
committerLars Wirzenius <liw@liw.fi>2017-07-05 13:56:13 +0300
commit8fa119d399bc92bf57d25986521b65742ced38a9 (patch)
tree40551dad7a5394b2ad5c7d7c52de5873dd8675d4 /debian
parentc9b5388d3e5079e67f5437aa131fd1c6d917b6d0 (diff)
downloadcoverage-test-runner-8fa119d399bc92bf57d25986521b65742ced38a9.tar.gz
Add: a Python3 version of the package
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control19
-rw-r--r--debian/copyright4
-rwxr-xr-xdebian/rules8
4 files changed, 20 insertions, 13 deletions
diff --git a/debian/changelog b/debian/changelog
index 0a292ba..8ec5106 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,7 +2,7 @@ python-coverage-test-runner (1.12+git-1) UNRELEASED; urgency=low
* New upstream version.
* debian/control: Raise Python dependency to 2.7 or later.
- * debian/control: Raise Standards-Version to 3.9.8. No other changes needed.
+ * debian/control: Raise Standards-Version to 4.0.0. No other changes needed.
* debian/control: Raise dependency on debhelper to 9 or later.
-- Lars Wirzenius <liw@liw.fi> Sun, 25 Oct 2015 13:17:24 +0200
diff --git a/debian/control b/debian/control
index 636c728..ee10de6 100644
--- a/debian/control
+++ b/debian/control
@@ -3,14 +3,23 @@ Maintainer: Lars Wirzenius <liw@liw.fi>
Homepage: http://liw.fi/coverage-test-runner/
Section: python
Priority: optional
-Standards-Version: 3.9.8
-Build-Depends: debhelper (>= 9), python-all (>= 2.7~),
- python-coverage
-X-Python-Version: >= 2.7
+Standards-Version: 4.0.0
+Build-Depends: debhelper (>= 9), dh-python,
+ python-all (>= 2.7~), python-coverage,
+ python3-all, python3-coverage
Package: python-coverage-test-runner
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}, python (>= 2.7), python-coverage
+Depends: ${misc:Depends}, ${python:Depends}, python-coverage
+Description: fail Python program unit tests unless they test everything
+ This package contains the Python module CoverageTestRunner, which runs
+ unit tests implemented using the unittest module in the Python standard
+ library. It runs them using coverage.py (in the python-coverage package)
+ and fails the test if all statements are not covered.
+
+Package: python3-coverage-test-runner
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}, python3-coverage
Description: fail Python program unit tests unless they test everything
This package contains the Python module CoverageTestRunner, which runs
unit tests implemented using the unittest module in the Python standard
diff --git a/debian/copyright b/debian/copyright
index e094a33..6ad9cfa 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,10 +1,10 @@
-Format: http://dep.debian.net/deps/dep5/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: coverage-test-runner
Upstream-Contact: Lars Wirzenius <liw@liw.fi>
Source: http://code.liw.fi/coverage-test-runner/bzr/trunk/
Files: *
-Copyright: 2007-2011, Lars Wirzenius
+Copyright: 2007-2017, Lars Wirzenius
License: GPL-3+
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
diff --git a/debian/rules b/debian/rules
index 56de9e6..89ba205 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,6 @@
#!/usr/bin/make -f
-%:
- dh $@ --with=python2 --buildsystem=python_distutils
+export PYBUILD_NAME=coverage-test-runner
-override_dh_auto_clean:
- $(MAKE) clean
- dh_auto_clean --buildsystem=python_distutils
+%:
+ dh $@ --with=python2,python3 --buildsystem=pybuild