summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@iki.fi>2008-05-22 08:24:09 +0300
committerLars Wirzenius <liw@iki.fi>2008-05-22 08:24:09 +0300
commit12abeecd99f2bf677d6b553a257d0ecaac7f748d (patch)
tree5060cf2666a6b120e286e0cf3ed3ee4662b6f044 /debian
parenta6d1f2a44c2e4f11d6d18d5731cf00179d6c0508 (diff)
downloadextrautils-12abeecd99f2bf677d6b553a257d0ecaac7f748d.tar.gz
Added initial .deb packaging.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control25
-rw-r--r--debian/copyright21
-rw-r--r--debian/pycompat1
-rwxr-xr-xdebian/rules12
6 files changed, 65 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..d8bf6aa
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+extrautils (1.0-1) unstable; urgency=low
+
+ * First upload.
+
+ -- Lars Wirzenius <liw@iki.fi> Sun, 18 May 2008 19:13:47 +0300
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..1b3e096
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,25 @@
+Source: extrautils
+Maintainer: Lars Wirzenius <liw@iki.fi>
+Section: misc
+Priority: optional
+Standards-Version: 3.7.3
+Build-Depends: cdbs (>= 0.4.43), debhelper (>= 5.0.38),
+ python-central (>= 0.5.6), python
+XS-Python-Version: all
+Homepage: http://iki.fi/extrautils/
+
+Package: extrautils
+Architecture: any
+Depends: ${python:Depends}, ${shlibs:Depends}, awk
+XB-Python-Version: ${python:Versions}
+Description: collection of miscellaneous Unix command line utilities
+ This is a collection of miscellaneous utilities for the Unix command
+ line, inspired by Joey Hess's moreutils. The inclusion criteria for
+ extrautils is much less strict than for moreutils: extrautils basically
+ welcomes utilities for any purpose, implemented in any language, as long
+ as they are well made and the author is willing to help with maintenance.
+ .
+ Currently included utilities:
+ * do-until: execute a command until it succeeds
+ * isascii: check whether a file consists of ASCII characters only
+ * total: add up all numbers in the first column
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..404a67f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,21 @@
+Extrautils was originally written Lars Wirzenius <liw@iki.fi>.
+It was originally packaged as a .deb by Lars Wirzenius <liw@iki.fi>.
+
+# Copyright (C) 2008 Lars Wirzenius <liw@iki.fi>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+On a Debian system, you can find a copy of the GPL version 2 in
+/usr/share/common-licenses/GPL-2.
diff --git a/debian/pycompat b/debian/pycompat
new file mode 100644
index 0000000..0cfbf08
--- /dev/null
+++ b/debian/pycompat
@@ -0,0 +1 @@
+2
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d9e147a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM=pycentral
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
+
+build/extrautils::
+ $(MAKE)
+
+clean::
+ $(MAKE) clean