summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2009-10-31 17:13:27 +0200
committerLars Wirzenius <liw@liw.fi>2009-10-31 17:13:27 +0200
commitabcc56d337726a06b2cf3a1a1703a861c432deb6 (patch)
tree169bcd9d607911fbcc67753c7d0122856711e912 /debian
parent7b6184b2c5236786d71e1306d527b31950a184d0 (diff)
downloadextrautils-abcc56d337726a06b2cf3a1a1703a861c432deb6.tar.gz
Re-did packaging so it uses dh instead of cdbs.
Dropped Python packaging helpers: I'm only installing simple scripts and I can't be bothered with the helpers. A simple dependency on the python package should be enough to keep things working. Added some missing stuff to install. Updated package long description.
Diffstat (limited to 'debian')
-rw-r--r--debian/compat2
-rw-r--r--debian/control14
-rwxr-xr-xdebian/rules15
3 files changed, 13 insertions, 18 deletions
diff --git a/debian/compat b/debian/compat
index 7ed6ff8..7f8f011 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-5
+7
diff --git a/debian/control b/debian/control
index 1a64cb7..b65ca8a 100644
--- a/debian/control
+++ b/debian/control
@@ -3,15 +3,12 @@ Maintainer: Lars Wirzenius <liw@iki.fi>
Section: misc
Priority: optional
Standards-Version: 3.7.3
-Build-Depends: cdbs (>= 0.4.43), debhelper (>= 5.0.38),
- python-central (>= 0.5.6), python, python-all-dev (>= 2.3.5-11)
-XS-Python-Version: all
-Homepage: http://iki.fi/extrautils/
+Build-Depends: debhelper (>= 7.3.15)
+Homepage: http://liw.fi/extrautils/
Package: extrautils
Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
+Depends: python (>= 2.5), ${shlibs:Depends}
Description: collection of miscellaneous Unix command line utilities
This is a collection of miscellaneous utilities for the Unix command
line, inspired by Joey Hess's moreutils. The inclusion criteria for
@@ -20,6 +17,9 @@ Description: collection of miscellaneous Unix command line utilities
as they are well made and the author is willing to help with maintenance.
.
Currently included utilities:
+ - corrupt: toggle a randomly chosen bit in a file
- do-until: execute a command until it succeeds
+ - errno: look up errno names, values, explanations
- isascii: check whether a file consists of ASCII characters only
- - total: add up all numbers in the first column
+ - minimify: find best tool to compress a given file
+ - onerror: execute command, show its output only if it fails
diff --git a/debian/rules b/debian/rules
index d9e147a..c69f807 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,7 @@
#!/usr/bin/make -f
-DEB_PYTHON_SYSTEM=pycentral
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/python-distutils.mk
-
-build/extrautils::
- $(MAKE)
-
-clean::
- $(MAKE) clean
+%:
+ dh $@
+
+override_dh_auto_install:
+ $(MAKE) install prefix=debian/extrautils