summaryrefslogtreecommitdiff
path: root/setuppy-debian-versions-match
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2021-03-12 08:10:42 +0200
committerLars Wirzenius <liw@liw.fi>2021-03-12 08:24:06 +0200
commit466fcd268e53743ca7414f1fe969a74cd0ac1ee1 (patch)
tree18056390e7f507c1f40b38edfaa4c218b840f0e7 /setuppy-debian-versions-match
parent2a562fd5a7d935d3743f6746927236b40f891a5c (diff)
downloadextrautils-466fcd268e53743ca7414f1fe969a74cd0ac1ee1.tar.gz
drop old crap
Diffstat (limited to 'setuppy-debian-versions-match')
-rwxr-xr-xsetuppy-debian-versions-match29
1 files changed, 0 insertions, 29 deletions
diff --git a/setuppy-debian-versions-match b/setuppy-debian-versions-match
deleted file mode 100755
index 4af4e5c..0000000
--- a/setuppy-debian-versions-match
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-#
-# setuppy-debian-versions-match - do setup.py and debian/changelog agree?
-# Copyright 2010 Lars Wirzenius
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-
-v1="$(python setup.py --version)"
-v2="$(dpkg-parsechangelog | awk '/^Version:/ { print $2 }' | sed 's/-[^-]*$//')"
-
-if [ "$v1" != "$v2" ]
-then
- echo "setup.py report version $v1" 1>&2
- echo "debian/changelog reports version $v2" 1>&2
- echo "they do not match!"
- exit 1
-fi