summaryrefslogtreecommitdiff
path: root/setuppy-debian-versions-match
diff options
context:
space:
mode:
Diffstat (limited to 'setuppy-debian-versions-match')
-rwxr-xr-xsetuppy-debian-versions-match29
1 files changed, 0 insertions, 29 deletions
diff --git a/setuppy-debian-versions-match b/setuppy-debian-versions-match
deleted file mode 100755
index 4af4e5c..0000000
--- a/setuppy-debian-versions-match
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-#
-# setuppy-debian-versions-match - do setup.py and debian/changelog agree?
-# Copyright 2010 Lars Wirzenius
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-
-v1="$(python setup.py --version)"
-v2="$(dpkg-parsechangelog | awk '/^Version:/ { print $2 }' | sed 's/-[^-]*$//')"
-
-if [ "$v1" != "$v2" ]
-then
- echo "setup.py report version $v1" 1>&2
- echo "debian/changelog reports version $v2" 1>&2
- echo "they do not match!"
- exit 1
-fi