summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2017-04-01 19:31:55 +0300
committerLars Wirzenius <liw@liw.fi>2017-04-01 19:31:55 +0300
commit3017b1b73c845b1185586f90cc4e5fe6c7c2367e (patch)
tree2b7e83dbf696566ffcbd6d33d5aa838d465f785c /setup.py
parent2749e79c17325bc6ee475f324cf077e9c312fcca (diff)
downloadick2-3017b1b73c845b1185586f90cc4e5fe6c7c2367e.tar.gz
Add setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f9fc0f3
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+#!/usr/bin/python
+# Copyright (C) 2017 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+from distutils.core import setup, Extension
+import glob
+
+import ick2lib
+
+setup(
+ name='ick2',
+ version=ick2lib.__version__,
+ description='CI server',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/ick/',
+ scripts=[],
+ packages=[],
+ data_files=[],
+)