summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2020-09-18 08:35:35 +0300
committerLars Wirzenius <liw@liw.fi>2020-09-18 19:49:55 +0300
commit070e7709ff0d18488ada3dcad38ac57ef73c3bef (patch)
tree215b32d7212c16493b29b19cdfb94e44140ee424 /Cargo.toml
parentaa3dd026c9a8c8407bccea0f1345f777afe0090c (diff)
downloadobnam2-070e7709ff0d18488ada3dcad38ac57ef73c3bef.tar.gz
feat: add a rudimentary chunk server main program
Also, add an initial subplot to document and verify acceptance criteria.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0f10594..5575cc8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,10 +4,14 @@ version = "0.1.0"
authors = ["Lars Wirzenius <liw@liw.fi>"]
edition = "2018"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
[dependencies]
anyhow = "1"
+bytes = "0.5"
serde = { version = "1", features = ["derive"] }
serde_json = "1"
+serde_yaml = "0.8"
+structopt = "0.3"
+thiserror = "1"
+tokio = { version = "0.2", features = ["macros"] }
uuid = { version = "0.8", features = ["v4"] }
+warp = { version = "0.2", features = ["tls"] }