summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2021-03-03 07:32:10 +0200
committerLars Wirzenius <liw@liw.fi>2021-03-03 07:33:01 +0200
commit671f13b29235abbfc7137571d596f5f784aa6b0b (patch)
tree13ee5561db96f38ff6e638ea165547945ff0e0f0 /Cargo.toml
parent0103bec1fb4f8290c78c35dfe832e88733ac6e16 (diff)
downloadobnam2-671f13b29235abbfc7137571d596f5f784aa6b0b.tar.gz
feat: store user and group who own each file
Actually, these aren't yet actually stored in the backup. That will happen when there's a way to verify file metadata stored in the backup. But this adds the code to look up the data during a backup so that at least that part gets some exercise.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d36c450..e9bd95e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -30,6 +30,7 @@ structopt = "0.3"
tempfile = "3.1"
thiserror = "1"
tokio = { version = "0.2", features = ["macros"] }
+users = "0.11"
uuid = { version = "0.8", features = ["v4"] }
walkdir = "2"
warp = { version = "0.2", features = ["tls"] }