summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2020-09-28 09:10:45 +0300
committerLars Wirzenius <liw@liw.fi>2020-10-03 10:34:56 +0300
commit864e20652458c1a4ae09c882ad3e29d6b0988b06 (patch)
tree2e08a43a4deb3759153105a8a3a4495faa3f9121 /Cargo.toml
parent164c5bfc707e21ebc1f1bf6bfb89e4adc2332ef0 (diff)
downloadobnam2-864e20652458c1a4ae09c882ad3e29d6b0988b06.tar.gz
feat: add rudimentary backup client
Also, a bit of logging for server.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5575cc8..e8d0e30 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,9 +7,14 @@ edition = "2018"
[dependencies]
anyhow = "1"
bytes = "0.5"
+indicatif = "0.15"
+log = "0.4"
+pretty_env_logger = "0.4"
+reqwest = { version = "0.10", features = ["blocking", "json"]}
serde = { version = "1", features = ["derive"] }
serde_json = "1"
serde_yaml = "0.8"
+sha2 = "0.9"
structopt = "0.3"
thiserror = "1"
tokio = { version = "0.2", features = ["macros"] }