summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2012-02-09 22:50:19 +0000
committerLars Wirzenius <liw@liw.fi>2012-02-09 22:50:19 +0000
commit1026e773893602cc9e1f064b441021714fa0438a (patch)
tree0c86de11d183ba37984bb7994a49d0b4779f18dd /setup.py
parentbefca55012597c7f50d015a4dff07d957e90c10e (diff)
downloadsummain-1026e773893602cc9e1f064b441021714fa0438a.tar.gz
Hardcode version number in setup.py to avoid build loop
setup.py used to import summainlib, and this used to work fine. Now, however, summainlib imports _summain, and we thus need to build the C extension before it can be imported. Catch-22, eh.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 7853233..c65e013 100644
--- a/setup.py
+++ b/setup.py
@@ -17,10 +17,8 @@
from distutils.core import setup, Extension
-import summainlib
-
setup(name='summain',
- version=summainlib.__version__,
+ version='0.10',
description='create file manifests with checksums',
author='Lars Wirzenius',
author_email='liw@liw.fi',