summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..35dcb6d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,31 @@
+# setup.py - distutils module for Dimbola
+# Copyright (C) 2009 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+from distutils.core import setup
+
+setup(name='summain',
+ version='0.0',
+ description='file manifest and checksum generator',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ py_modules=['summainlib'],
+ scripts=['summain'],
+ data_files=[
+ ('share/man/man1', ['summain.1']),
+ ],
+ )
+