summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNeil Williams <codehelp@debian.org>2015-08-15 17:01:37 +0200
committerNeil Williams <codehelp@debian.org>2015-08-16 14:28:53 +0200
commit4076819572f4dec90050771a58a4753d20a3f68b (patch)
tree633060d5b03ef7f323368c0dc345c9334b04f9fd /setup.py
parent54b1ab7ea71a857791189d7a2108c8b76cbfde2a (diff)
downloadvmdebootstrap-4076819572f4dec90050771a58a4753d20a3f68b.tar.gz
add setuptools support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py48
1 files changed, 48 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..1c59145
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,48 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+#
+# setup.py
+#
+# Copyright 2015 Neil Williams <codehelp@debian.org>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name='vmdebootstrap',
+ version='1.0',
+ description='Bootstrap Debian into a (virtual machine) disk image',
+ author='Neil Williams',
+ author_email='codehelp@debian.org',
+ url='http://git.liw.fi/cgi-bin/cgit/cgit.cgi/vmdebootstrap/',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU Lesser General Public License v3 or later (LGPLv3+)',
+ 'Programming Language :: Python',
+ 'Topic :: System :: Installation/Setup',
+ ],
+ packages=[
+ 'vmdebootstrap',
+ ],
+ package_data={
+ 'vmdebootstrap': ['README', 'COPYING', 'NEWS'],
+ },
+ scripts=['bin/vmdebootstrap']
+)