summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2013-08-14 20:03:54 +0100
committerLars Wirzenius <liw@liw.fi>2013-08-14 20:03:54 +0100
commit5b042d5679e1d61e432bd7812ac81d45a574dcda (patch)
tree8476bad817ad76ee3191dc391fb8a0babdefb1ad /setup.py
parentac303ee5ec7c41adb5ff712e81c5b6030c7109a8 (diff)
downloadclab-5b042d5679e1d61e432bd7812ac81d45a574dcda.tar.gz
Add a setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..bfcc596
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,28 @@
+#!/usr/bin/python
+# Copyright (C) 2013 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+from distutils.core import setup, Extension
+import glob
+
+setup(name='clab',
+ version='0.0',
+ description='command line address book',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/clab/',
+ scripts=['clab'],
+ )