summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-06-12 13:37:11 +0100
committerLars Wirzenius <liw@liw.fi>2011-06-12 13:37:11 +0100
commit105c6d6907c035943e76406230cc61539f2261b5 (patch)
treef385559e8eae8839d96723d2edc015aae50b7378 /debian/rules
parent336d437706c574df523992817f21e9498017ff7f (diff)
downloadcliapp-105c6d6907c035943e76406230cc61539f2261b5.tar.gz
Update packaging to use dh_python2, and debian/changelog for release.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 4 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 9511c43..5c4c882 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,8 @@
#!/usr/bin/make -f
+
%:
- dh $@ --with-buildsystem=python_distutils
+ dh $@ --with=python2 --buildsystem=python_distutils
-override_dh_auto_install:
- python setup.py install --prefix=debian/python-cliapp/usr
-
override_dh_auto_build:
- if command -v setuppy-debian-versions-match > /dev/null; then \
- setuppy-debian-versions-match; fi
- dh_auto_build $@ --with-buildsystem=python_distutils
-
+ $(MAKE)
+ dh_auto_build --with=python2 --buildsystem=python_distutils