summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-01-20 20:23:30 +0000
committerLars Wirzenius <liw@liw.fi>2011-01-20 20:23:30 +0000
commit2b936ed02e06b96365c03cdb6b57dc053ec02490 (patch)
treebe7b0f302788cb94b019f6650940458e62fac7f2 /debian/rules
parent05835aff12353e1b7314f4e03b41b8f0336ac144 (diff)
downloadcliapp-2b936ed02e06b96365c03cdb6b57dc053ec02490.tar.gz
Add Debian packaging.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..fb8abf6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+%:
+ dh $@ --with-buildsystem=python_distutils
+
+override_dh_auto_install:
+ python setup.py install --prefix=debian/python-cliapp/usr
+
+override_dh_auto_build:
+ setuppy-debian-versions-match
+ dh_auto_build $@ --with-buildsystem=python_distutils
+