summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-01-20 22:13:05 +0200
committerLars Wirzenius <liw@liw.fi>2011-01-20 22:13:05 +0200
commit61bf663f1373cd8af9c33cefea2a20d21851102d (patch)
tree3add4361bbfa50ab2b392ae64843971df5fbb50a /setup.py
parentfb2e5e6d5f9b44845c28d9d73dec92f516f8f8a9 (diff)
downloadcliapp-61bf663f1373cd8af9c33cefea2a20d21851102d.tar.gz
Add setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..044424b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/python
+# Copyright (C) 2011 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+from distutils.core import setup, Extension
+import glob
+
+setup(name='cliapp',
+ version='0.1',
+ description='Framework for Unix command line applications',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/cliapp/',
+ packages=['cliapp'],
+ )
+