summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-06-08 14:13:50 +0100
committerLars Wirzenius <liw@liw.fi>2011-06-08 14:13:50 +0100
commit9a0f44e7a57178105ebd84b6a0d057b1a2443925 (patch)
tree98c26e40d0e1af3704e6958d326c833bd5f795ea /setup.py
parentb3710b79b786564eb08c6a6211251f6711c91967 (diff)
downloadcliapp-9a0f44e7a57178105ebd84b6a0d057b1a2443925.tar.gz
Fix up setup.py so it's ready for PyPI.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 20 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e48b10b..799a9d0 100644
--- a/setup.py
+++ b/setup.py
@@ -15,16 +15,34 @@
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-from distutils.core import setup, Extension
+from distutils.core import setup
import cliapp
setup(name='cliapp',
version=cliapp.__version__,
- description='Framework for Unix command line applications',
author='Lars Wirzenius',
author_email='liw@liw.fi',
url='http://liw.fi/cliapp/',
+ description='framework for Unix command line programs',
+ long_description='''\
+cliapp makes it easier to write typical Unix command line programs,
+by taking care of the common tasks they need to do, such as
+parsing the command line, reading configuration files, setting
+up logging, iterating over lines of input files, and so on.
+''',
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: Unix',
+ 'Programming Language :: Python :: 2',
+ 'Topic :: Software Development :: Libraries :: Application Frameworks',
+ 'Topic :: Software Development :: User Interfaces',
+ 'Topic :: Text Processing :: Filters',
+ 'Topic :: Utilities',
+ ],
packages=['cliapp'],
)