summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2015-04-18 11:18:54 +0300
committerLars Wirzenius <liw@liw.fi>2015-04-18 15:41:49 +0300
commita09e1064f58673591093df7f3b709a775c06b866 (patch)
tree173e13e3a3293e4a1871bb1fa2bb1ad3cd07d938 /setup.py
parentd3b79bed48895150fb7c33f577716a900fda3833 (diff)
downloadcliapp-a09e1064f58673591093df7f3b709a775c06b866.tar.gz
Add running of pylint in 'make check' and fix things
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 18 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 2ed1543..6a7024d 100644
--- a/setup.py
+++ b/setup.py
@@ -21,19 +21,20 @@ import glob
import cliapp
-setup(name='cliapp',
- version=cliapp.__version__,
- author='Lars Wirzenius',
- author_email='liw@liw.fi',
- url='http://liw.fi/cliapp/',
- description='framework for Unix command line programs',
- long_description='''\
-cliapp makes it easier to write typical Unix command line programs,
-by taking care of the common tasks they need to do, such as
-parsing the command line, reading configuration files, setting
-up logging, iterating over lines of input files, and so on.
-''',
- classifiers=[
+setup(
+ name='cliapp',
+ version=cliapp.__version__,
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/cliapp/',
+ description='framework for Unix command line programs',
+ long_description='''\
+ cliapp makes it easier to write typical Unix command line programs,
+ by taking care of the common tasks they need to do, such as
+ parsing the command line, reading configuration files, setting
+ up logging, iterating over lines of input files, and so on.
+ ''',
+ classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Console',
'Intended Audience :: Developers',
@@ -44,7 +45,7 @@ up logging, iterating over lines of input files, and so on.
'Topic :: Software Development :: User Interfaces',
'Topic :: Text Processing :: Filters',
'Topic :: Utilities',
- ],
- packages=['cliapp'],
- data_files=[('share/man/man5', glob.glob('*.5'))],
- )
+ ],
+ packages=['cliapp'],
+ data_files=[('share/man/man5', glob.glob('*.5'))],
+)