summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichel Alexandre Salim <salimma@fedoraproject.org>2015-09-03 22:30:45 +0700
committerLars Wirzenius <liw@liw.fi>2015-09-07 20:55:03 +0300
commit98c463a64b6f5b46ddaa1cff21037463a50da2bd (patch)
treeea3793d250c477a5462139510675ef487e21a82f /setup.py
parent78e45103420511807a500325db5f18c679575e16 (diff)
downloadcmdtest-98c463a64b6f5b46ddaa1cff21037463a50da2bd.tar.gz
coverage-4.0a6 compatibility
coverage 4.0a6 no longer generates .coverage file, so check first if it exists before attempting removal.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f9af20f..c83e02b 100644
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,8 @@ class Check(Command):
subprocess.check_call(
['python', '-m', 'CoverageTestRunner',
'--ignore-missing-from', 'without-tests'])
- os.remove('.coverage')
+ if os.path.exists('.coverage'):
+ os.remove('.coverage')
subprocess.check_call(['./cmdtest', 'echo-tests'])
subprocess.check_call(['./cmdtest', 'sort-tests'])