summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f9af20f..c83e02b 100644
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,8 @@ class Check(Command):
subprocess.check_call(
['python', '-m', 'CoverageTestRunner',
'--ignore-missing-from', 'without-tests'])
- os.remove('.coverage')
+ if os.path.exists('.coverage'):
+ os.remove('.coverage')
subprocess.check_call(['./cmdtest', 'echo-tests'])
subprocess.check_call(['./cmdtest', 'sort-tests'])