summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@iki.fi>2007-12-12 22:37:39 +0200
committerLars Wirzenius <liw@iki.fi>2007-12-12 22:37:39 +0200
commit94b16dc4ed88a7bad4b8d6dcb0e3804c24e408dd (patch)
treeab95d566db86e32c8d89c53a22c522ad33711245 /setup.py
parent4acca2a3bbb6cbdb8bbd76270d9aaa20041c04c6 (diff)
downloadcoverage-test-runner-94b16dc4ed88a7bad4b8d6dcb0e3804c24e408dd.tar.gz
Wrote setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..558c0d6
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+from distutils.core import setup
+
+setup(name='CoverageTestRunner',
+ version='1.0',
+ description='fail Python program unit tests unless they test everything',
+ long_description='''\
+CoverageTestRunner runs unit tests implemented using the unittest module
+in the Python standard library. It runs them using coverage.py and fails
+the test if all statements are not covered.
+''',
+ author='Lars Wirzenius',
+ author_email='liw@iki.fi',
+ url='http://braawi.org/coveragetestrunner.html',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Testing',
+ ],
+ license='GNU General Public License, version 2 or later',
+ py_modules=['CoverageTestRunner'],
+ )