summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2013-04-28 09:41:33 +0100
committerLars Wirzenius <liw@liw.fi>2013-04-28 09:41:33 +0100
commite73f86ee2f5cc06c0c25b3caf552280bc29c5d8f (patch)
tree98a99a9722f72cd6a014adb4c7fbe1db0800694a /setup.py
parent4487d167b7d34e0d89991062d467aa6c67b4bb25 (diff)
downloaddesktop-cronish-e73f86ee2f5cc06c0c25b3caf552280bc29c5d8f.tar.gz
Add setup.py for installation etc
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..995a3b8
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+#!/usr/bin/python
+# Copyright (C) 2013 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+from distutils.core import setup
+
+setup(name='desktop-cronish',
+ version='0.0',
+ description='git://git.gitano.org.uk/personal/liw/desktop-cronish',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/desktop-cronish/',
+ scripts=['desktop-cronish'],
+ )