summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 11 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 1895664..5630649 100644
--- a/setup.py
+++ b/setup.py
@@ -55,17 +55,20 @@ class Check(Command):
self.set_all_options(True)
def run(self):
- if self.unit_tests:
- self.run_unit_tests()
+ try:
+ if self.unit_tests:
+ self.run_unit_tests()
- if self.yarns:
- self.run_yarns()
+ if self.yarns:
+ self.run_yarns()
- if self.pep8 and self.command_is_available('pep8'):
- self.run_pep8()
+ if self.pep8 and self.command_is_available('pep8'):
+ self.run_pep8()
- if self.pylint and self.command_is_available('pylint'):
- self.run_pylint()
+ if self.pylint and self.command_is_available('pylint'):
+ self.run_pylint()
+ except cliapp.AppException:
+ raise SystemExit(1)
def run_unit_tests(self):
cliapp.runcmd(