summaryrefslogtreecommitdiff
path: root/setuppy-debian-versions-match
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2010-05-11 00:21:10 +1200
committerLars Wirzenius <liw@liw.fi>2010-05-11 00:21:10 +1200
commit63f2632c0e5858b149fa93b2bfbcd09bba81102b (patch)
tree3f40839450eb9bf170748b6b8e2760d11a0ae18f /setuppy-debian-versions-match
parentdf3b5e323cd17742da5847ee1e27eccf93e521e2 (diff)
downloadextrautils-63f2632c0e5858b149fa93b2bfbcd09bba81102b.tar.gz
Add setuppy-debian-versions-match.
Diffstat (limited to 'setuppy-debian-versions-match')
-rwxr-xr-xsetuppy-debian-versions-match29
1 files changed, 29 insertions, 0 deletions
diff --git a/setuppy-debian-versions-match b/setuppy-debian-versions-match
new file mode 100755
index 0000000..4af4e5c
--- /dev/null
+++ b/setuppy-debian-versions-match
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# setuppy-debian-versions-match - do setup.py and debian/changelog agree?
+# Copyright 2010 Lars Wirzenius
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+v1="$(python setup.py --version)"
+v2="$(dpkg-parsechangelog | awk '/^Version:/ { print $2 }' | sed 's/-[^-]*$//')"
+
+if [ "$v1" != "$v2" ]
+then
+ echo "setup.py report version $v1" 1>&2
+ echo "debian/changelog reports version $v2" 1>&2
+ echo "they do not match!"
+ exit 1
+fi