summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@iki.fi>2007-07-13 03:43:15 +0300
committerLars Wirzenius <liw@iki.fi>2007-07-13 03:43:15 +0300
commit2e809d8923dd528181e2694794b0a607951fafd3 (patch)
treeb4d675874c5fece53078c94db4033ab18cbb419c /setup.py
parenta6b1afe9b0aa1aaf187f899ae2094501f202aaf3 (diff)
downloadgenbackupdata-2e809d8923dd528181e2694794b0a607951fafd3.tar.gz
Added more meta data to setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 04d8ef4..02c118b 100644
--- a/setup.py
+++ b/setup.py
@@ -3,8 +3,34 @@ from distutils.core import setup
setup(name='genbackupdata',
version='1.0',
description='Generate test data for backup software',
+ long_description='''\
+genbackupdata creates or modifies directory trees in ways that simulate
+real filesystems sufficiently well for performance testing of backup
+software. For example, it can create files that are a mix of small text
+files and big binary files, with the binary files containing random
+binary junk which compresses badly. This can then be backed up, and
+later the directory tree can be changed by creating new files, modifying
+files, or deleting or renaming files. The backup can then be run again.
+
+The output is deterministic, such that for a given set of parameters the
+same output always happens. Thus it is more efficient to distribute
+genbackupdata and a set of parameters between people who wish to
+benchmark backup software than distributing very large test sets.
+''',
author='Lars Wirzenius',
author_email='liw@iki.fi',
url='http://braawi.org/genbackupdata.html',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Testing',
+ 'Topic :: System :: Archiving :: Backup',
+ ],
+ license='GNU General Public License, version 2 or later',
py_modules=['genbackupdata'],
) \ No newline at end of file