summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2015-07-03 18:58:55 +0300
committerLars Wirzenius <liw@liw.fi>2015-07-03 18:58:55 +0300
commitdae004dcf2272c054c4f546341fa1a07f84fa8bc (patch)
tree5ab8b9c0cc8d806f78f4a41deeaa3c28b7caf024 /setup.py
parent16f6b133966af326ce4caebff2771dc9916c31b0 (diff)
downloadick-dae004dcf2272c054c4f546341fa1a07f84fa8bc.tar.gz
Add setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..8398a2d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,44 @@
+#!/usr/bin/python
+# Copyright (C) 2015 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+
+from distutils.core import setup
+
+
+setup(
+ name='ick',
+ version='0.0',
+ description='continuous integration system',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Console',
+ 'Environment :: Handhelds/PDAs',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python :: 2',
+ 'Topic :: Home Automation',
+ 'Topic :: Software Development :: Build Tools',
+ 'Topic :: Software Development :: Quality Assurance',
+ 'Topic :: Software Development :: Testing',
+ ],
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/ick/',
+ scripts=['ick'],
+ packages=['icklib'],
+)