summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2014-03-22 16:17:29 +0000
committerLars Wirzenius <liw@liw.fi>2014-03-22 16:17:29 +0000
commitc415f519c5496bb652853a50790aa665fc2139ef (patch)
treeca7657ccb50b69e28ec2d75e2c137349e2c5c97d /setup.py
parent01473d28bb06a476421f2621dcca6389398843d8 (diff)
downloadjt-tmp-c415f519c5496bb652853a50790aa665fc2139ef.tar.gz
Preliminary Debian packaging
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..fcf3c7b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+#!/usr/bin/python
+# Copyright (C) 2014 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+from distutils.core import setup
+
+setup(name='jt',
+ version='0.0',
+ description='personal journalling tool',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/jt/',
+ scripts=['jt'],
+ )