summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2020-09-05 14:42:08 +0300
committerLars Wirzenius <liw@liw.fi>2020-09-05 18:31:23 +0300
commit33683712604607d85f20cbf93a7ac904552f4979 (patch)
treefc37020f3b0c8220e096c33d4f63008a612174c9 /Cargo.toml
parentbddb592c4cb89e76796b17dd5bed823eba7e2b0e (diff)
downloadjt2-33683712604607d85f20cbf93a7ac904552f4979.tar.gz
feat: create and initialise a new journal
At the moment this only creates a new directory, but most of the change is scaffolding so that more interesting changes can be built on top of this later.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..2066c46
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,10 @@
+[package]
+name = "jt2"
+version = "0.1.0"
+authors = ["Lars Wirzenius <liw@liw.fi>"]
+edition = "2018"
+
+[dependencies]
+structopt = "0.3"
+anyhow = "1"
+thiserror = "1"