summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-06-27 22:26:27 +0100
committerLars Wirzenius <liw@liw.fi>2011-06-27 22:26:27 +0100
commite267252c41b72d4dcb6a476a5951832a123df732 (patch)
tree281428b3f11cc41d993d7f6cd6a4f4662006f358 /debian
parentf2109abbbb15bcfec520d75c446c78359768741d (diff)
downloadlarch-e267252c41b72d4dcb6a476a5951832a123df732.tar.gz
Improve Debian package description
Diffstat (limited to 'debian')
-rw-r--r--debian/control16
1 files changed, 14 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index a1a15f9..14be9f8 100644
--- a/debian/control
+++ b/debian/control
@@ -14,5 +14,17 @@ Depends: ${python:Depends}, ${misc:Depends}, python (>= 2.5),
python-lru (>= 0.4), python-tracing, python-cliapp
XB-Python-Version: ${python:Versions}
Description: B-tree library for Python
- The larch Python library implements the copy-on-write B-trees designed by
- Odah Rodeh.
+ An implementation of a particular kind of B-tree, based on research
+ by Ohad Rodeh. This is the same data structure that btrfs uses, but
+ in a new, pure-Python implementation.
+ .
+ The distinctive feature of this B-tree is that a node is never (conceptually)
+ modified. Instead, all updates are done by copy-on-write. This makes it
+ easy to clone a tree, and modify only the clone, while other processes
+ access the original tree.
+ .
+ The implementation is generic and flexible, so that you may use it in
+ a variety of situations. For example, the tree itself does not decide
+ where its nodes are stored: you provide a class that does that for it.
+ The library contains two implementations, one for in-memory and one
+ for on-disk storage.