summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-06-28 10:42:48 +0100
committerLars Wirzenius <liw@liw.fi>2011-06-28 10:42:48 +0100
commitafaafda0b3674a9f26839a218d134d1ab40409c8 (patch)
treecf9e65367a4a7eb73602952758709391f2804f84 /setup.py
parent9981f3b6f5c8e2eeb52d3d9435c3e5ac2f4b77a0 (diff)
downloadlarch-afaafda0b3674a9f26839a218d134d1ab40409c8.tar.gz
Update setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 26 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 40ea2c6..8210ea5 100644
--- a/setup.py
+++ b/setup.py
@@ -21,9 +21,34 @@ import larch
setup(
name='larch',
version=larch.version,
- description='B-tree data structure',
+ description='copy-on-write B-tree data structure',
+ long_description='''\
+An implementation of a particular kind of B-tree, based on research
+by Ohad Rodeh. This is the same data structure that btrfs uses, but
+in a new, pure-Python implementation.
+
+The distinctive feature of this B-tree is that a node is never (conceptually)
+modified. Instead, all updates are done by copy-on-write. This makes it
+easy to clone a tree, and modify only the clone, while other processes
+access the original tree.
+
+The implementation is generic and flexible, so that you may use it in
+a variety of situations. For example, the tree itself does not decide
+where its nodes are stored: you provide a class that does that for it.
+The library contains two implementations, one for in-memory and one
+for on-disk storage.
+''',
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2',
+ 'Topic :: Software Development :: Libraries',
+ ],
author='Lars Wirzenius',
author_email='liw@liw.fi',
url='http://liw.fi/larch/',
packages=['larch'],
)
+