summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2010-05-08 11:57:08 +1200
committerLars Wirzenius <liw@liw.fi>2010-05-08 11:57:08 +1200
commitcf1cdfe2a7d8817490f199b11d946d366d6dbfaa (patch)
treec48dde98baf3f0810d6f160595d0e4d803cfeb45 /setup.py
parent8dcdbe8f529da69756cc24be754a96f2fbddd50c (diff)
downloadlarch-cf1cdfe2a7d8817490f199b11d946d366d6dbfaa.tar.gz
Add a setup.py script.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f552156
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+# Copyright 2010 Lars Wirzenius
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+from distutils.core import setup
+
+import btree
+
+setup(
+ name='btree',
+ version=btree.version,
+ description='B-tree data structure',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://liw.fi/btree/',
+ packages=['btree'],
+)