summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2018-11-09 12:47:23 +0200
committerLars Wirzenius <liw@liw.fi>2018-11-09 13:03:09 +0200
commitaf45ff11f46d4c1a1e4d0776782c1b18dc41ca56 (patch)
tree040ea9d4399f001e2a78a4b16cf30b5498931dda /setup.py
parentccc9b9f17eb08977cee1fba425a2876a004266b5 (diff)
downloadmuck-poc-af45ff11f46d4c1a1e4d0776782c1b18dc41ca56.tar.gz
Add: Debian packaging
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..20b17b7
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+#!/usr/bin/python3
+# Copyright (C) 2018 Lars Wirzenius <liw@liw.fi>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+from distutils.core import setup
+
+import muck
+
+
+setup(
+ name='muck-poc',
+ version=muck.__version__,
+ description='JSON store',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+ url='http://ick.liw.fi',
+ packages=['muck'],
+ scripts=[
+ 'muck_poc'
+ ],
+)