summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-08-28 16:23:26 +0100
committerLars Wirzenius <liw@liw.fi>2011-08-28 16:23:26 +0100
commitb77cd342e1e69eb55fdb300daacb3eb45e996341 (patch)
tree3e77c32b2059d27c1c1f6b5443d5d4b34dcb1a2f /debian/rules
parent231955ccda82701bf0e9b56fea60260298301ab7 (diff)
downloadobnam-b77cd342e1e69eb55fdb300daacb3eb45e996341.tar.gz
Use GPGHOME for the right command...
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 52515d16..2fef26e7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,8 @@
dh $@ --with=python2 --with-buildsystem=python_distutils
override_dh_auto_test:
+ python setup.py build_ext -i
+ rm -rf build
cp -a test-gpghome temp.gpghome
- env GNUPGHOME=temp.gpghome python setup.py build_ext -i
- rm -rf build temp.gpghome
- python setup.py check
+ env GNUPGHOME=temp.gpghome python setup.py check
+ rm -rf temp.gpghome