summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2014-12-29 21:38:15 +0200
committerLars Wirzenius <liw@liw.fi>2014-12-29 21:38:15 +0200
commit261587b864817adf495cdab985e0a87bc62ba177 (patch)
tree5339315e6b2ae333bdff871039d5c49d49893465 /setup.py
parent4c07a954c42b4985faec6834db4fe3ac81b67cbd (diff)
downloadobnam-261587b864817adf495cdab985e0a87bc62ba177.tar.gz
Pass to yarn if given
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a59fd7f9..351a6e0e 100755
--- a/setup.py
+++ b/setup.py
@@ -168,6 +168,9 @@ class Check(Command):
if self.yarns and got_yarn:
runcmd(
['yarn', '-s', 'yarns/obnam.sh'] +
+ ['--env',
+ 'REPOSITORY_FORMAT=' +
+ os.environ.get('REPOSITORY_FORMAT', '6')] +
glob.glob('yarns/*.yarn'))
num_clients = '2'