summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2015-07-04 16:32:03 +0300
committerLars Wirzenius <liw@liw.fi>2015-07-04 16:32:03 +0300
commit4417aee6f26adabc46552b53481656d9e37281b1 (patch)
tree16c671c1f1089f09142a5c17f231ab0ce17d8240 /setup.py
parent572faf19054c59bf6ecf181b448c4392b35548df (diff)
downloadobnam-4417aee6f26adabc46552b53481656d9e37281b1.tar.gz
Cleanups suggested by pep8
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fc37738a..a020ac13 100755
--- a/setup.py
+++ b/setup.py
@@ -234,6 +234,7 @@ class Check(Command):
runcmd(['./test-sftpfs'])
def run_nitpick_checks(self):
+ self.check_with_pep8(sources)
if os.path.exists('.git'):
sources = self.find_all_source_files()
self.check_sources_for_nitpicks(sources)
@@ -241,6 +242,9 @@ class Check(Command):
else:
print "no .git, no nitpick for you"
+ def check_with_pep8(self):
+ cliapp.runcmd(['pep8', 'obnamlib'], stdout=None, stderr=None)
+
def check_sources_for_nitpicks(self, sources):
cliapp.runcmd(['./nitpicker'] + sources, stdout=None, stderr=None)