summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2015-06-21 21:42:32 +0300
committerLars Wirzenius <liw@liw.fi>2015-06-21 21:42:32 +0300
commita0ab2d6b70a13da6d187a7effe45f2be470bdd92 (patch)
treef98042124e1aeb0c07ccd266e3a663ca6cf5fbc7 /setup.py
parent163fa4550b6395e1f99b37fb53b5c66469770cd4 (diff)
downloadobnam-a0ab2d6b70a13da6d187a7effe45f2be470bdd92.tar.gz
Don't run nitpicks if no .git
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 05cedc9b..242d85ce 100755
--- a/setup.py
+++ b/setup.py
@@ -232,9 +232,12 @@ class Check(Command):
runcmd(['./test-sftpfs'])
def run_nitpick_checks(self):
- sources = self.find_all_source_files()
- self.check_sources_for_nitpicks(sources)
- self.check_copyright_statements(sources)
+ if os.path.exists('.git'):
+ sources = self.find_all_source_files()
+ self.check_sources_for_nitpicks(sources)
+ self.check_copyright_statements(sources)
+ else:
+ print "no .git, no nitpick for you"
def check_sources_for_nitpicks(self, sources):
cliapp.runcmd(['./nitpicker'] + sources, stdout=None, stderr=None)