summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2015-01-24 21:37:56 +0200
committerLars Wirzenius <liw@liw.fi>2015-01-24 21:37:56 +0200
commita1373f0542b75dbc340211d4d89391d352ba76a4 (patch)
treeee70ffdc8d7ee1efd639ac38184ce1c56db18ff7 /setup.py
parent6dd22c72687c834f74e9e2575256672666c53193 (diff)
downloadobnam-a1373f0542b75dbc340211d4d89391d352ba76a4.tar.gz
Fix setup.py to run yarn with all repo formats by default
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 11 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 351a6e0e..c1336f70 100755
--- a/setup.py
+++ b/setup.py
@@ -166,12 +166,17 @@ class Check(Command):
os.remove('.coverage')
if self.yarns and got_yarn:
- runcmd(
- ['yarn', '-s', 'yarns/obnam.sh'] +
- ['--env',
- 'REPOSITORY_FORMAT=' +
- os.environ.get('REPOSITORY_FORMAT', '6')] +
- glob.glob('yarns/*.yarn'))
+ if 'REPOSITORY_FORMAT' in os.environ:
+ formats = [os.environ['REPOSITORY_FORMAT']]
+ else:
+ formats = ['6', 'simple']
+
+ for format in formats:
+ print 'run yarn for repository format %s' % format
+ runcmd(
+ ['yarn', '-s', 'yarns/obnam.sh'] +
+ ['--env', 'REPOSITORY_FORMAT=' + format] +
+ glob.glob('yarns/*.yarn'))
num_clients = '2'
num_generations = '16'