summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2015-03-26 21:33:42 +0200
committerLars Wirzenius <liw@liw.fi>2015-03-26 21:33:42 +0200
commita2a8718a3ed5a2ce8b1515fa276909e305cc211a (patch)
tree2701f1a3c8190aaf4fc0f995c5c6ad613aa7ee68 /setup.py
parent3ae521f2d1eae1b174bdedb7f53a36fb77adc356 (diff)
downloadobnam-a2a8718a3ed5a2ce8b1515fa276909e305cc211a.tar.gz
Use list-formats instead of hardcoding format list
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d7c54a11..05cedc9b 100755
--- a/setup.py
+++ b/setup.py
@@ -199,7 +199,7 @@ class Check(Command):
if 'REPOSITORY_FORMAT' in os.environ:
return [os.environ['REPOSITORY_FORMAT']]
else:
- return ['6', 'simple']
+ return cliapp.runcmd(['./obnam', 'list-formats']).splitlines()
def run_yarn_for_repo_format(self, repo_format):
print 'run yarn for repository format %s' % repo_format