summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2015-02-27 18:27:46 +0100
committerLars Wirzenius <liw@liw.fi>2015-03-22 14:07:22 +0200
commitbece5d28349ac226713537bef07f85af65b96a26 (patch)
treec3003da386da80106f1ac0a3ea55dde2e3eb75a0 /setup.py
parent787478a81bbc7c1c74ed5c0f2d5ef26022ec4e42 (diff)
downloadobnam-bece5d28349ac226713537bef07f85af65b96a26.tar.gz
avoid shadowing builtins
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 9b541810..15f37f91 100755
--- a/setup.py
+++ b/setup.py
@@ -192,8 +192,8 @@ class Check(Command):
os.remove('.coverage')
def run_yarn(self):
- for format in self.get_wanted_formats():
- self.run_yarn_for_repo_format(format)
+ for repo_format in self.get_wanted_formats():
+ self.run_yarn_for_repo_format(repo_format)
def get_wanted_formats(self):
if 'REPOSITORY_FORMAT' in os.environ:
@@ -201,11 +201,11 @@ class Check(Command):
else:
return ['6', 'simple']
- def run_yarn_for_repo_format(self, format):
- print 'run yarn for repository format %s' % format
+ def run_yarn_for_repo_format(self, repo_format):
+ print 'run yarn for repository format %s' % repo_format
runcmd(
['yarn', '-s', 'yarns/obnam.sh'] +
- ['--env', 'REPOSITORY_FORMAT=' + format] +
+ ['--env', 'REPOSITORY_FORMAT=' + repo_format] +
glob.glob('yarns/*.yarn'))
def run_lock_test(self, num_clients, num_generations):