summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2014-04-13 16:40:38 +0100
committerLars Wirzenius <liw@liw.fi>2014-04-13 16:40:38 +0100
commitd8c1689a7fe5966dec55d370a6ad82b9926e0b37 (patch)
tree11d833aadef747de380dca024bbdb6faa46e0ba4 /setup.py
parent3c8f3b98de78d3af85b2ea3542df2eb3fdac4c6a (diff)
downloadobnam-d8c1689a7fe5966dec55d370a6ad82b9926e0b37.tar.gz
Expand TAB chars when checking line lengths
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 73545492..480c15c1 100644
--- a/setup.py
+++ b/setup.py
@@ -194,6 +194,7 @@ class Check(Command):
max_line_length = 80
with open(filename) as f:
for i, line in enumerate(f):
+ line = line.expandtabs()
if len(line) >= max_line_length:
print 'LONG: %s: %d: %s' % (filename, i+1, line),