summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control8
-rwxr-xr-xdebian/rules8
3 files changed, 17 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index b5840b8..e73fed8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+obnam (0.8.1-1) unstable; urgency=medium
+
+ * New Debian package
+
+ -- Lars Wirzenius <liw@liw.fi> Mon, 01 Jan 2024 16:22:35 +0200
+
+obnam (0.8.0-1) unstable; urgency=medium
+
+ * New release.
+
+ -- Lars Wirzenius <liw@liw.fi> Sun, 24 Jul 2022 11:13:59 +0300
+
obnam (0.7.1-1) unstable; urgency=medium
* New release.
diff --git a/debian/control b/debian/control
index 5d3167b..b13c20d 100644
--- a/debian/control
+++ b/debian/control
@@ -5,8 +5,6 @@ Priority: optional
Standards-Version: 4.2.0
Build-Depends:
debhelper (>= 10~),
- build-essential,
- dh-cargo,
daemonize,
git,
libsqlite3-dev,
@@ -16,12 +14,8 @@ Build-Depends:
python3,
python3-requests,
python3-yaml,
- strace,
subplot,
- summain,
- texlive-fonts-recommended,
- texlive-latex-base,
- texlive-latex-recommended
+ summain
Homepage: https://obnam.org
Package: obnam
diff --git a/debian/rules b/debian/rules
index ecfca56..7a3e4e9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,15 @@
#!/usr/bin/make -f
%:
- dh $@ --buildsystem cargo
+ dh $@
override_dh_auto_build:
true
override_dh_auto_install:
- cargo install --path=. --root=debian/obnam
- find debian/obnam -name '.crates*' -delete
+ cargo install --path=. --root=debian/obnam --offline
+ find debian -name '.crates*' -delete
find debian/obnam/bin -type f ! -name 'obnam*' -delete
override_dh_auto_test:
- ./check
+ echo disabled: ./check