summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2021-11-29 12:49:12 +0200
committerLars Wirzenius <liw@liw.fi>2021-11-29 18:31:17 +0200
commita73ab1321d0646655e3415094aa46a36da67d315 (patch)
treee82a2133619e9db7945336484d8a1450d4b7e5d5 /Cargo.toml
parent1d982b22f51468d87d9577d06007d107b67fe532 (diff)
downloadpandoc-filter-diagram-a73ab1321d0646655e3415094aa46a36da67d315.tar.gz
feat: add basic features
Add rendering of dot, plantuml, pikchr, roadmap, and raw SVG, from fenced code blocks into SVG. Sponsored-by: pep.foundation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 07b3b4d..1c3d0c8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,23 @@
name = "pandoc-filter-diagram"
version = "0.1.0"
edition = "2021"
+authors = [
+ "Lars Wirzenius <liw@liw.fi>",
+ "Daniel Silverstone <dsilvers@digital-scurf.org>",
+]
+license = "MIT-0"
+description = '''render diagram markup in a Pandoc abstract syntax tree as SVG'''
+repository = "https://gitlab.com/larswirzenius/pandoc-filter-diagram"
+
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+anyhow = "1.0.50"
+base64 = "0.13.0"
+pandoc_ast = "0.8.0"
+pikchr = "0.1.1"
+roadmap = "0.3.0"
+serde = { version = "1.0.101", features = ["derive"] }
+serde_json = "1.0.72"
+thiserror = "1.0.30"