summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@sequoia-pgp.org>2022-08-16 10:28:45 +0300
committerLars Wirzenius <liw@sequoia-pgp.org>2022-08-16 10:28:45 +0300
commite60c3dc46e3889f29fac70cc6be1530e2741a2f2 (patch)
tree445b2e12ae601b283184d860cb1d424e6fbe89cb /Cargo.toml
parent9e4b36106da5620fcb2985e6a83cc67be3e314c1 (diff)
downloadpandoc-filter-diagram-e60c3dc46e3889f29fac70cc6be1530e2741a2f2.tar.gz
fix: deal with Pandoc AST versioning
Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ed32d8c..4c8f5ff 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,10 +11,16 @@ description = '''render diagram markup in a Pandoc abstract syntax tree as SVG''
repository = "https://gitlab.com/larswirzenius/pandoc-filter-diagram"
rust-version = "1.56.0"
+[features]
+default = ["ast_07"]
+ast_07 = ["pandoc_ast_07"]
+ast_08 = ["pandoc_ast_08"]
+
[dependencies]
anyhow = "1.0.50"
base64 = "0.13.0"
-pandoc_ast = "0.8.0"
+pandoc_ast_07 = { package = "pandoc_ast", version = "0.7", optional = true }
+pandoc_ast_08 = { package = "pandoc_ast", version = "0.8", optional = true }
pikchr = "0.1.1"
roadmap = "0.4.3"
serde = { version = "1.0.101", features = ["derive"] }