summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-06-28 11:33:30 +0100
committerLars Wirzenius <liw@liw.fi>2011-06-28 11:33:30 +0100
commit5cfc6c06566e230d67e336269e14b09fb4e0d9fe (patch)
treef5fbb885710342ad97819413f6a00670832e180a /debian/rules
parent83401758c5c23034de0036d404c60e427f0b9be1 (diff)
downloadpython-tracing-5cfc6c06566e230d67e336269e14b09fb4e0d9fe.tar.gz
Update packaging to use dh_python2.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 8 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 48e0eb1..37a2644 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,13 @@
#!/usr/bin/make -f
+
%:
- dh $@ --with-buildsystem=python_distutils
+ dh $@ --with=python2 --buildsystem=python_distutils
-override_dh_auto_install:
- python setup.py install --prefix=debian/python-tracing/usr
-
override_dh_auto_build:
- if command -v setuppy-debian-versions-match > /dev/null; then \
- setuppy-debian-versions-match; fi
- dh_auto_build $@ --with-buildsystem=python_distutils
+ $(MAKE)
+ dh_auto_build --with=python2 --buildsystem=python_distutils
+
+override_dh_auto_clean:
+ $(MAKE) clean
+ dh_auto_clean --with=python2 --buildsystem=python_distutils