summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorVincent Sanders <vince@kyllikki.org>2017-09-04 10:32:37 +0100
committerVincent Sanders <vince@kyllikki.org>2017-09-04 10:32:37 +0100
commit30dee92479798786be0cd5b48f8e10bdee06a135 (patch)
treea424cb021892d8bd08810d83f4106d5f4f75e48c /setup.py
parent9fc7cc1201acb4b4c8b0d2ade62b5c3d2f5f8c5d (diff)
downloadqvisqve-30dee92479798786be0cd5b48f8e10bdee06a135.tar.gz
basic python setuptools files
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c7c4387
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,34 @@
+#!/usr/bin/python
+#
+# setup.py - standard Python build-and-package program
+#
+# Copyright 2017 Vincent Sanders <vince@qvarnlabs.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+from setuptools import setup
+
+import qvarn
+
+
+setup(
+ name='qvarn',
+ version=qvarn.__version__,
+ description='backend service for JSON and binary data storage',
+ author='Lars Wirzenius',
+ author_email='liw@qvarnlabs.com',
+ packages=['qvarn'],
+ scripts=['qvarnbackend.py'],
+)