summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2022-06-13 09:35:52 +0300
committerLars Wirzenius <liw@liw.fi>2022-06-24 11:12:07 +0300
commit796da8edcc2541a5343bdc53ae21e12c04419f52 (patch)
treefbb22a30082073774f8f6c90ac6e1bf0eb138a95 /Cargo.toml
parentf5fe497d7f55b31d47be59771649c2019b0265a2 (diff)
downloadriki-796da8edcc2541a5343bdc53ae21e12c04419f52.tar.gz
feat: rudimentary HTML generation
This handles paragraphs and h1 headings, for now. More to come later. There's also some testing. Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 92c7c1a..175abd1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,3 +12,13 @@ pulldown-cmark = "0.9.0"
structopt = "0.3.25"
thiserror = "1.0.31"
walkdir = "2.3.2"
+
+[build-dependencies]
+subplot-build = "0.4.0"
+
+[dev-dependencies]
+subplotlib = { git = "https://gitlab.com/subplot/subplot.git" }
+fehler = "1.0.0"
+pandoc = "0.8.9"
+pandoc_ast = "0.8.0"
+serde_json = "1.0.81"