summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2022-09-24 11:23:25 +0300
committerLars Wirzenius <liw@liw.fi>2022-09-28 12:33:29 +0300
commitf31bbc127f68a46bb4337cd4d149e1b470cb8dbb (patch)
tree0cddb0e69f03fb7c2bb7e7674a7752ca3129097a /Cargo.toml
parentf253698b8794d9992bf075c6e4b793dca0887794 (diff)
downloadriki-f31bbc127f68a46bb4337cd4d149e1b470cb8dbb.tar.gz
feat: implement PageSpec expressions
This is just the expressions, they aren't used by any directives yet. Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 48ef2a6..c3612e6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,6 +9,8 @@ anyhow = "1.0.52"
clap = { version = "3.2.10", features = ["derive"] }
git-testament = "0.2.1"
html-escape = "0.2.11"
+lalrpop = "0.19.8"
+lalrpop-util = "0.19.8"
libc = "0.2.126"
log = "0.4.17"
pretty_env_logger = "0.4.0"
@@ -20,6 +22,7 @@ time = { version = "0.3.13", features = ["macros", "parsing"] }
walkdir = "2.3.2"
[build-dependencies]
+lalrpop = "0.19.8"
subplot-build = "0.5.0"
[dev-dependencies]