summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2022-01-21 09:34:47 +0200
committerLars Wirzenius <liw@liw.fi>2022-01-21 10:09:41 +0200
commitf49a7c9eaa14ce1aaf342d862ec292b84fa2e7bc (patch)
treee81eb68c3626715c541644e9055c2bd8c709fee9 /Cargo.toml
parent82073da80b0f38d605204e96bf4b430c2b785813 (diff)
downloadroadmap-f49a7c9eaa14ce1aaf342d862ec292b84fa2e7bc.tar.gz
refactor: parse with serde directly to data structure
Use serde to parse directly to a hashmap of steps, instead of generic YAML values. This gives us better error messages. Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a5f1129..40ef824 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,7 @@ repostiory = "https://gitlab.com/larswirzenius/roadmap"
[dependencies]
anyhow = "1"
+serde = { version = "1.0.134", features = ["derive"] }
serde_yaml = "0.8"
structopt = "0.3"
textwrap = "0.14"