summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorLars Wirzenius <liw@localhost>2014-06-03 13:09:32 +0000
committerLars Wirzenius <liw@localhost>2014-06-03 13:09:32 +0000
commit315db640f463613cae4de4c02cc52d2be6d5684a (patch)
tree3a922456821d1882c778267f04bbf0c4d0bfca68 /data/Makefile.am
downloadsoundconverter-debian-packaging-master.tar.gz
Initial import for soundconverter 2.1.3HEADmaster
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
new file mode 100644
index 0000000..36094ea
--- /dev/null
+++ b/data/Makefile.am
@@ -0,0 +1,39 @@
+## Process this file with automake to produce Makefile.in
+
+gladedir = $(datadir)/soundconverter
+dist_glade_DATA = soundconverter.glade soundconverter-logo.svg
+
+icondir = $(datadir)/icons/hicolor/48x48/apps
+dist_icon_DATA = soundconverter.png
+
+svgicondir = $(datadir)/icons/hicolor/scalable/apps
+dist_svgicon_DATA = soundconverter.svg
+
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(datadir)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+desktop_in_files= soundconverter.desktop.in
+
+desktop_files=$(desktop_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
+
+Applicationsdir = $(datadir)/applications
+Applications_DATA = $(desktop_files)
+
+appdatadir = $(datadir)/appdata
+dist_appdata_DATA = soundconverter.appdata.xml
+
+EXTRA_DIST = $(desktop_in_files) $(desktop_files)
+
+DISTCLEANFILES = $(desktop_files)